"Revit failed to start" or "RevitWorker.exe was not found." when launching Revit (autodesk.com) 


Issue:

Revit fails to start and one of the following messages appears:

Revit 2024 and later versions

Revit initialization failure

Revit failed to start
Please click "learn More" below to diagnose and correct the issue.
Revit failed to start.pngLines similar to the following are written to the Revit journal file:

DBG_WARN: Failed to launch Worker: line 203 of E:\Ship\2024_px64\Source\Revit\RevitDB\Managers\MultiProcessImpl.cpp. Failed to create worker 1 


Revit 2023 and earlier versions

RevitWorker.exe was not found.

Revit cannot restart because it is missing a component. You must reinstall the application.
 


Also, Revit may crash with a CER before the software start screen appears.

The Revit journal file records lines similar to the following: 

' 1:< DBG_WARN: failed to create message_queue named 'Session1764_P0MasterQueue' because boost::interprocess::intermodule_singleton initialization failed: line 202 of NOBLE\ManageWorkerServices.cpp. ' 1:< DBG_WARN: Could not establish Worker Services!: line 140 of NOBLE\ManageWorkerServices.cpp. 'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging finished virtualization services  'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging finished worker services  'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging erased queues  ' 0:< TaskDialog "RevitWorker.exe was not found."

Causes:

  • Cybereason blocks the RevitWorker process.
  • RevitWorker.exe set to “Run this program as an administrator”.
  • Windows issues. 
    • Pending/Missing/Corrupter Windows Update.
    • Permission rights.
    • Corrupted Windows Management Instrumentation Service (WMI).

Solution:

Cybereason

If Cybereason software is running on the system, try temporarily disabling this.

If the error is cleared when disabling, check for updates to the software and work with Cybereason support to prevent it from interacting with the RevitWorker process.


RevitWorker.exe Running as Administrator

If the RevitWorker process is run as an administrator while the Revit process is not, then Revit will not be able to properly communicate with the RevitWorker. Test if this is happening, by going through the following steps:

  1. Right click the Revit icon (from the Desktop or Windows Start menu)
  2. Select Run as Administrator.
    • If you don't have administrative rights available to run Revit as an administrator, work with your computer/operating system support to do this test.
  3. If the error is cleared, then this indicates RevitWorker is running as admin.
Fix RevitWorker
 
If you've confirmed that RevitWorker is running as admin, go through the following steps to change this:
  1. Go to the Revit installation directory (it would be by default C:\Program Files\Autodesk\Revit ####).

  2. Right click the RevitWorker.exe file and select “Properties”.

  3. Select the “Compatibility” tab.

  4. Clear both the “Compatibility mode” and “Run this program as an administrator”.

  5. Select apply and then OK.

  6. Start Revit normally (without using “Run as Administrator”).

 

Windows issues

Problems with the Windows setup/configuration can lead to this behavior. Check with your computer/operating system support on the following topics:

  • System Information "Can't Collect Information":
Go through the following steps to check if this issue is occurring:
  1. Click Windows Start.

  2. Type msinfo32.exe.

  3. Click System Information (App).

  4. Check if System Information shows "Can't Collect Information" as shown in the following picture.

image

If this is confirmed, it indicates that the Windows Management Instrumentation service is not working properly. Run the following batch script to restore the Windows Management Instrumentation functionality.
  1. Open Notepad (Start -> Run -> Notepad) or other text editor.

  2. Add the following text (copy/paste): 

@echo on cd /d c:\temp if not exist %windir%\system32\wbem goto TryInstall cd /d %windir%\system32\wbem net stop winmgmt winmgmt /kill if exist Rep_bak rd Rep_bak /s /q rename Repository Rep_bak for %%i in (*.dll) do RegSvr32 -s %%i for %%i in (*.exe) do call :FixSrv %%i for %%i in (*.mof,*.mfl) do Mofcomp %%i net start winmgmt goto End 
:FixSrv if /I (%1) == (wbemcntl.exe) goto SkipSrv if /I (%1) == (wbemtest.exe) goto SkipSrv if /I (%1) == (mofcomp.exe) goto SkipSrv %1 /Regserver :SkipSrv goto End :TryInstall if not exist wmicore.exe goto End wmicore /s net start winmgmt :End
  1. Save the document with the name WBEM_Fix.bat in the folder C:\Autodesk (location can be changed but avoid the Desktop or user folders).

  2. Right click the BAT file and select Run as administrator.

  3. A Command prompt will appear and will perform several steps. Let the process run until it closes automatically.

  4. Start the Revit again.

Note: If the batch script doesn't clear the error, work with your computer/operating system support to resolve this Windows issue.

 

Other Troubleshooting

See the following article for troubleshooting on a similar issue (different symptoms similar journal entries): "Revit has stopped working" and then Revit shuts down